Documentation

Contents
Contents
Contents
Contents
!
This documentation applies to a beta version of uberAgent (docs for the latest official release)

System Requirements

Backend

Splunk

Operating system: all that are supported by Splunk

Splunk version: Splunk Enterprise 6.3 or newer or Splunk Cloud (details).

We only support uberAgent on Splunk software that is officially supported by Splunk (details).

Endpoints

Windows

Operating system:

  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows 10
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019

All Windows versions are supported in 32-bit (where applicable) and 64-bit. We only support uberAgent on Windows versions that are officially supported by Microsoft.

macOS

Operating system:

  • macOS 10.15 (Catalina) or above

Citrix Virtual Apps and Desktops, Microsoft RDS, VMware Horizon View

Remote desktop session hosts (e.g. Citrix XenApp/CVAD, VMware Horizon View, Microsoft RDS) are explicitly supported. The same applies to any kind of virtual desktop (e.g. Citrix XenDesktop/CVAD, VMware View).

Windows Virtual Desktop

uberAgent supports monitoring and analyzing the user experience and application performance of Windows Virtual Desktop (WVD) environments running on Microsoft Azure.

Windows Agent Service Account

The main component of uberAgent’s endpoint agent is a system service that needs to run as the local SYSTEM account because that is required by some APIs.

Browser Extensions

Chrome

Google Chrome 41 or newer

Edge

Microsoft Edge 80 or newer

Internet Explorer

Microsoft Internet Explorer 11

Firefox

Mozilla Firefox 50 or newer

Endpoint Agent Features

Citrix Virtual Apps and Desktops Site Monitoring

  • CVAD delivery controller version 7.6 or newer

Citrix ADC Monitoring

  • At least PowerShell version 3.0
  • At least Citrix ADC firmware version 10.5

Alternative Backends

Apache Kafka

  • Confluent REST Proxy 4.0 or newer
  • Confluent Schema Registry 4.0 or newer
  • Any Apache Kafka version supported by the Confluent components above

Elasticsearch & Kibana

  • At least Elasticsearch 5.6.x
  • At least Kibana 5.6.x

Microsoft Azure Log Analytics

  • No specific requirements

Leave a Reply

Your email address will not be published. Required fields are marked *